Skip to Main Content
Cognex Support Hub
LogoLogo

All Triggers are No Reads in Edge Intelligence

Troubleshooting for issue in Edge Intelligences where all triggers cause no reads

09/15/2024

Details

Issue
All triggers are being shown as no reads in Edge Intelligence.

 

Cause:
The line assigning is GoodRead in the primary reader's script may be missing.

 

Resolution:
You can verify this by comparing the Result Status in the Result History of the primary reader in setup tool with the values coming into Edge Intelligence. If good reads in setup tool are coming in as no reads in Edge Intelligence, the value is likely not being assigned.

Add the line edgeIntelligenceResult.payload.isGoodRead = output.events.system === Event.system.goodRead; to the primary reader's script.

Related Resources