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VisionPro Deep Learning API - "Failed to Load Library"

Workaround for Failure to Load Library Error in VisionPro Deep Learning (VPDL)

15/09/2024

Details

Issue:

"Failed to load library" error occurs when using API.

Causes:

The System Environment Variable for VisionPro Deep Learning is not on the top of the list.

Resolution:

Edit Path variable in System environment variables to move VisionPro Deep Learning to the top:

  1. In Search, search for and then select: System (Control Panel)
  2. Click the Advanced system settings.
  3. Click Environment Variables.
  4. In the section System variables click Path environment variable and click Edit.

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  5. Find "C:\Program Files\Cognex\VisionPro Deep Learning\2.1\bin" on the list and click Move Up to move this path to the top of the list.

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  6. Click OK and restart VisionPro Deep Learning. 

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