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Querying for Triggers Restarts Stack

Fix for issue with Querying in Edge Intelligence

15/09/2024

Details

Issue:

When loading triggers for unspecified or default time range, the data never loads, and we get an error message "Could not retrieve list of triggers".

Following that Edge Intelligence becomes unresponsive.

Edge Intelligence connection gets restored after a minute or 2.

Cause:

This issue is caused by Data Processing API trying to query large amounts of data for large span of time. This problem can be sourced back to InfluxDb.

We can produce this problem in Chronograf too when querying for a large time range. The effects of this query can be felt on the terminal too. As soon as we query, the Putty terminal becomes unresponsive hinting massive disk operations on the system.

As a result of this, InfluxDB crashes and restarts. This leads to EI stack also rebooting as InfluxDB is a dependency for it. 

Resolution:

To resolve the issue, do the following:

  1. Ask Edge Intelligence support to identify if disk storage is full.
  2. Clear all databases from Edge Intelligence's UI. This option can be found at Settings → Edge Device → Clear Databases
  3. Reboot the box.

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