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How To Solve License Issue In VisionPro 9.1 After Uninstalling VisionPro 9.2

This article describes a possible reason and resolution if the license on the Cognex Security hardware (USB dongle, CC24 communication card, or framegrabber card) cannot be detected in VisionPro 9.1, but there was VisionPro 9.2 on the same computer before which was able to recognize the license.

03/25/2025

Details

Issue:

The license was working in VisionPro 9.2, but after downgrading to VisionPro 9.1 the license is not recognized, although Cognex Security Service is running. The Cogtool printout gives a message that "No compatible services detected":

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Causes:

The Cognex Security Service might be left over from the previous VisionPro installation and might not be compatible with the VisionPro 9.1 version.
To check this, navigate to the folder C:\Windows\SysWOW64\ and find the below files there:

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Right-click on cogss_srv, select Properties, then click on the Details tab. If you see a File version other than 2.4.0.0, then the issue is related to the incompatible Cognex Security Service version.

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Resolution:

  1. Uninstall Cognex VisionPro
  2. Open Command Prompt as an administrator, navigate to the C:\Windows\SysWOW64\ folder and execute the below:
    cogss_srv -remove
  3. Open File Explorer and navigate to the C:\Windows\SysWOW64\ folder and delete the below files from there:
    - cogss_install.exe
    - cogss_msg.dll
    - cogss_srv.exe

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  4. Uninstall Cognex x64 Drivers
  5. Reboot the computer
  6. Install Cognex VisionPro 9.1

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